package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(<a.*?href=".*?//.*?">.*?</a>)|(<a href="/.+/">dwdqwdqwd</a>)`)
var str = `dqwqwfqfewf fwefwef fwe fw fwefwefwe
fwefwefwefwefwefwefwefwef fwef.
<a href="/dwdw.php/">dwdqwdqwd</a>
fwefwefwefwefewfwefwefwefwfwefwefwefwefwefew.
dqwqwfqfewf fwefwef fwe fw fwefwefwe
<a href="//dwdw.php">dwdqwdqwd</a>
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}