const regex = new RegExp('(<a.*?href=".*?//.*?">.*?</a>)|(<a href="/.+/">dwdqwdqwd</a>)', 'g')
const str = `dqwqwfqfewf fwefwef fwe fw fwefwefwe
fwefwefwefwefwefwefwefwef fwef.
<a href="/dwdw.php/">dwdqwdqwd</a>
fwefwefwefwefewfwefwefwefwfwefwefwefwefwefew.
dqwqwfqfewf fwefwef fwe fw fwefwefwe
<a href="//dwdw.php">dwdqwdqwd</a>
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}