import re
regex = re.compile(r"(<a.*?href=\".*?//.*?\">.*?</a>)|(<a href=\"/.+/\">dwdqwdqwd</a>)")
test_str = ("dqwqwfqfewf fwefwef fwe fw fwefwefwe\n"
"fwefwefwefwefwefwefwefwef fwef.\n"
"<a href=\"/dwdw.php/\">dwdqwdqwd</a>\n"
"fwefwefwefwefewfwefwefwefwfwefwefwefwefwefew.\n"
"dqwqwfqfewf fwefwef fwe fw fwefwefwe\n"
"<a href=\"//dwdw.php\">dwdqwdqwd</a>\n\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")