// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"(<a.*?href=".*?//.*?">.*?</a>)|(<a href="/.+/">dwdqwdqwd</a>)"#).unwrap();
let string = "dqwqwfqfewf fwefwef fwe fw fwefwefwe
fwefwefwefwefwefwefwefwef fwef.
<a href=\"/dwdw.php/\">dwdqwdqwd</a>
fwefwefwefwefewfwefwefwefwfwefwefwefwefwefew.
dqwqwfqfewf fwefwef fwe fw fwefwefwe
<a href=\"//dwdw.php\">dwdqwdqwd</a>
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}