re = /(<a.*?href=".*?\/\/.*?">.*?<\/a>)|(<a href="\/.+\/">dwdqwdqwd<\/a>)/
str = 'dqwqwfqfewf fwefwef fwe fw fwefwefwe
fwefwefwefwefwefwefwefwef fwef.
<a href="/dwdw.php/">dwdqwdqwd</a>
fwefwefwefwefewfwefwefwefwfwefwefwefwefwefew.
dqwqwfqfewf fwefwef fwe fw fwefwefwe
<a href="//dwdw.php">dwdqwdqwd</a>
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end