#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(sin|cos|tan|cot|sec|csc)(?!.\([^)]*\))(h?)\s*(|\^\s*[\(]?\s*\-?\s*\d+\s*[\)]?\s*)?([a-z0-9]+)"
Local $sString = "sinh xyz"
Local $sSubst = "\1\2\3(\4)"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)