import re
regex = re.compile(r"(sin|cos|tan|cot|sec|csc)(?!.\([^)]*\))(h?)\s*(|\^\s*[\(]?\s*\-?\s*\d+\s*[\)]?\s*)?([a-z0-9]+)")
test_str = "sinh xyz"
subst = "\\1\\2\\3(\\4)"
result = regex.sub(subst, test_str, count=1)
if result:
print(result)