using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(sin|cos|tan|cot|sec|csc)(?!.\([^)]*\))(h?)\s*(|\^\s*[\(]?\s*\-?\s*\d+\s*[\)]?\s*)?([a-z0-9]+)";
string substitution = @"\1\2\3(\4)";
string input = @"sinh xyz";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution, 1);
}
}