const regex = /(sin|cos|tan|cot|sec|csc)(?!.\([^)]*\))(h?)\s*(|\^\s*[\(]?\s*\-?\s*\d+\s*[\)]?\s*)?([a-z0-9]+)/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(sin|cos|tan|cot|sec|csc)(?!.\\([^)]*\\))(h?)\\s*(|\\^\\s*[\\(]?\\s*\\-?\\s*\\d+\\s*[\\)]?\\s*)?([a-z0-9]+)', '')
const str = `sinh xyz`;
const subst = `\1\2\3(\4)`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);