#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)^(?=.*?[0-9])(?=(?:.*?[A-Za-z]){3})[a-zA-Z0-9]{6,}$"
Local $sString = "foobar9" & @CRLF & _
"foobar" & @CRLF & _
"fooba6" & @CRLF & _
"sh&gsgg" & @CRLF & _
"fo777777"
Local $sSubst = ""
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)