import re
regex = re.compile(r"^(?=.*?[0-9])(?=(?:.*?[A-Za-z]){3})[a-zA-Z0-9]{6,}$", flags=re.MULTILINE)
test_str = ("foobar9\n"
"foobar\n"
"fooba6\n"
"sh&gsgg\n"
"fo777777")
subst = ""
result = regex.sub(subst, test_str)
if result:
print(result)