using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(?=.*?[0-9])(?=(?:.*?[A-Za-z]){3})[a-zA-Z0-9]{6,}$";
string substitution = @"";
string input = @"foobar9
foobar
fooba6
sh&gsgg
fo777777";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}