$re = '/^(?=.*?[0-9])(?=(?:.*?[A-Za-z]){3})[a-zA-Z0-9]{6,}$/m';
$str = 'foobar9
foobar
fooba6
sh&gsgg
fo777777';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;