#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)^((\w[^\W]+)[\.\-]?){1,}\@(([0-9]{1,3}\.[0-9]{1,3}\.[0-9]{1,3}\.[0-9]{1,3})|(([a-zA-Z\-0-9]+\.)+[a-zA-Z]{2,}))$"
Local $sString = "JOAO!DA.SILVA@CNN,COM (INVALID)" & @CRLF & _
"joao@microsoft.com" & @CRLF & _
"mauricio.teste@site.ba.gov.br" & @CRLF & _
"santana.teste@sistema-ba.ba.gov.br" & @CRLF & _
"teste.teste.teste.igor.caza@google.com" & @CRLF & _
"teste.teste.teste.igor.caza@globo.com.br" & @CRLF & _
"ayslan-johnson@teste.com.br" & @CRLF & _
"joao@123.com" & @CRLF & _
"ayslanjohnson@google.com" & @CRLF & _
"teste.teste.teste.igor.caza@globo (INVALID)" & @CRLF & _
"SILVA.teste@SITE-ba.ba.gov.br. (INVALID)"
Local $sSubst = ""
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)