using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^((\w[^\W]+)[\.\-]?){1,}\@(([0-9]{1,3}\.[0-9]{1,3}\.[0-9]{1,3}\.[0-9]{1,3})|(([a-zA-Z\-0-9]+\.)+[a-zA-Z]{2,}))$";
string substitution = @"";
string input = @"JOAO!DA.SILVA@CNN,COM (INVALID)
joao@microsoft.com
mauricio.teste@site.ba.gov.br
santana.teste@sistema-ba.ba.gov.br
teste.teste.teste.igor.caza@google.com
teste.teste.teste.igor.caza@globo.com.br
ayslan-johnson@teste.com.br
joao@123.com
ayslanjohnson@google.com
teste.teste.teste.igor.caza@globo (INVALID)
SILVA.teste@SITE-ba.ba.gov.br. (INVALID)";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}