const regex = /^((\w[^\W]+)[\.\-]?){1,}\@(([0-9]{1,3}\.[0-9]{1,3}\.[0-9]{1,3}\.[0-9]{1,3})|(([a-zA-Z\-0-9]+\.)+[a-zA-Z]{2,}))$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^((\\w[^\\W]+)[\\.\\-]?){1,}\\@(([0-9]{1,3}\\.[0-9]{1,3}\\.[0-9]{1,3}\\.[0-9]{1,3})|(([a-zA-Z\\-0-9]+\\.)+[a-zA-Z]{2,}))$', 'gm')
const str = `JOAO!DA.SILVA@CNN,COM (INVALID)
joao@microsoft.com
mauricio.teste@site.ba.gov.br
santana.teste@sistema-ba.ba.gov.br
teste.teste.teste.igor.caza@google.com
teste.teste.teste.igor.caza@globo.com.br
ayslan-johnson@teste.com.br
joao@123.com
ayslanjohnson@google.com
teste.teste.teste.igor.caza@globo (INVALID)
SILVA.teste@SITE-ba.ba.gov.br. (INVALID)`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);