// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^((\w[^\W]+)[\.\-]?){1,}\@(([0-9]{1,3}\.[0-9]{1,3}\.[0-9]{1,3}\.[0-9]{1,3})|(([a-zA-Z\-0-9]+\.)+[a-zA-Z]{2,}))$").unwrap();
let string = "JOAO!DA.SILVA@CNN,COM (INVALID)
joao@microsoft.com
mauricio.teste@site.ba.gov.br
santana.teste@sistema-ba.ba.gov.br
teste.teste.teste.igor.caza@google.com
teste.teste.teste.igor.caza@globo.com.br
ayslan-johnson@teste.com.br
joao@123.com
ayslanjohnson@google.com
teste.teste.teste.igor.caza@globo (INVALID)
SILVA.teste@SITE-ba.ba.gov.br. (INVALID)";
let substitution = "";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}