package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^((\w[^\W]+)[\.\-]?){1,}\@(([0-9]{1,3}\.[0-9]{1,3}\.[0-9]{1,3}\.[0-9]{1,3})|(([a-zA-Z\-0-9]+\.)+[a-zA-Z]{2,}))$`)
var str = `JOAO!DA.SILVA@CNN,COM (INVALID)
joao@microsoft.com
mauricio.teste@site.ba.gov.br
santana.teste@sistema-ba.ba.gov.br
teste.teste.teste.igor.caza@google.com
teste.teste.teste.igor.caza@globo.com.br
ayslan-johnson@teste.com.br
joao@123.com
ayslanjohnson@google.com
teste.teste.teste.igor.caza@globo (INVALID)
SILVA.teste@SITE-ba.ba.gov.br. (INVALID)`
var substitution = ""
fmt.Println(re.ReplaceAllString(str, substitution))
}