# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(.*)\\/feed/\1\\//gm;t' <<< "https://$url/$uri/feed"