$re = '/(.*)\/feed/m';
$str = 'https://$url/$uri/feed';
$subst = "\1\/";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;