import Foundation
let pattern = #"(.*)\/feed"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"https://$url/$uri/feed"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"\1\/"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)