use strict;
my $str = 'https://$url/$uri/feed';
my $regex = qr/(.*)\/feed/mp;
my $subst = '\\1\\/';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";