#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?:[0-2]?[0-9]|3[01])\/(?:0?[1-9]|1[012])\/[0-9]{2}(?:[0-9]{2})?"
Local $sString = "1/1/1900" & @CRLF & _
"1/2/1999" & @CRLF & _
"00/00/0000" & @CRLF & _
"02/06/2016" & @CRLF & _
"01/10/00" & @CRLF & _
"99/99/9999" & @CRLF & _
"31/02/2017" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")