import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?:[0-2]?[0-9]|3[01])\\/(?:0?[1-9]|1[012])\\/[0-9]{2}(?:[0-9]{2})?";
final String string = "1/1/1900\n"
+ "1/2/1999\n"
+ "00/00/0000\n"
+ "02/06/2016\n"
+ "01/10/00\n"
+ "99/99/9999\n"
+ "31/02/2017\n";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}