import re
regex = re.compile(r"(?:[0-2]?[0-9]|3[01])\/(?:0?[1-9]|1[012])\/[0-9]{2}(?:[0-9]{2})?")
test_str = ("1/1/1900\n"
"1/2/1999\n"
"00/00/0000\n"
"02/06/2016\n"
"01/10/00\n"
"99/99/9999\n"
"31/02/2017\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")