$re = '/(?:[0-2]?[0-9]|3[01])\/(?:0?[1-9]|1[012])\/[0-9]{2}(?:[0-9]{2})?/';
$str = '1/1/1900
1/2/1999
00/00/0000
02/06/2016
01/10/00
99/99/9999
31/02/2017
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);