using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?:[0-2]?[0-9]|3[01])\/(?:0?[1-9]|1[012])\/[0-9]{2}(?:[0-9]{2})?";
string input = @"1/1/1900
1/2/1999
00/00/0000
02/06/2016
01/10/00
99/99/9999
31/02/2017
";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}