const regex = /(?:[0-2]?[0-9]|3[01])\/(?:0?[1-9]|1[012])\/[0-9]{2}(?:[0-9]{2})?/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?:[0-2]?[0-9]|3[01])\\\/(?:0?[1-9]|1[012])\\\/[0-9]{2}(?:[0-9]{2})?', 'g')
const str = `1/1/1900
1/2/1999
00/00/0000
02/06/2016
01/10/00
99/99/9999
31/02/2017
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}