package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`!!!\s*([^?]+?)\s*\?{3}`)
var str = `Image 56 ::: Beach, Summer, Sun !!! John Smith ???
Image 57 ::: Beach, Summer, Sun !!!Jane Doe???
Image 58 ::: Beach, Summer, Sun !!! Jack Johnson???`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}