re = /!!!\s*([^?]+?)\s*\?{3}/
str = 'Image 56 ::: Beach, Summer, Sun !!! John Smith ???
Image 57 ::: Beach, Summer, Sun !!!Jane Doe???
Image 58 ::: Beach, Summer, Sun !!! Jack Johnson???'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end