// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"!!!\s*([^?]+?)\s*\?{3}").unwrap();
let string = "Image 56 ::: Beach, Summer, Sun !!! John Smith ???
Image 57 ::: Beach, Summer, Sun !!!Jane Doe???
Image 58 ::: Beach, Summer, Sun !!! Jack Johnson???";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}