import re
regex = re.compile(r"!!!\s*([^?]+?)\s*\?{3}")
test_str = ("Image 56 ::: Beach, Summer, Sun !!! John Smith ???\n"
"Image 57 ::: Beach, Summer, Sun !!!Jane Doe???\n"
"Image 58 ::: Beach, Summer, Sun !!! Jack Johnson???")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")