package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?mi)league/((?P<league_slug>[\w-]+)(/(?P<season_slug>\d{4}(-\d{4})?))?(/(?P<action_slug>[\w\-\_]+[(-|_)]?[\w]+))?)?(/)?`)
var str = `http://localhost:8010/league
http://localhost:8010/league/
http://localhost:8010/league/serie-a
http://localhost:8010/league/serie-a/
http://localhost:8010/league/serie-a/2016
http://localhost:8010/league/serie-a/2016/
http://localhost:8010/league/serie-a/2015-2016
http://localhost:8010/league/serie-a/2015-2016/
http://localhost:8010/league/serie-a/s-t-a-n-d-i-n-g-s
http://localhost:8010/league/serie-a/stand_-aasdings/
http://localhost:8010/league/serie-a/2016/standings
http://localhost:8010/league/serie-a/2016/standings/
http://localhost:8010/league/2016
http://localhost:8010/league/2016/
http://localhost:8010/league/standings
http://localhost:8010/league/standings/`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}