#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?>\S)(\s)(?>")"
Local $sString = "{" & @CRLF & _
" "assessmentID": 289," & @CRLF & _
" "assesmentName": " OneCert "," & @CRLF & _
" "accountName": " spadmin "," & @CRLF & _
" "assetName": " OneCert "," & @CRLF & _
" "applicationName": " OneCert "," & @CRLF & _
" "accountType": " LocalAccount "," & @CRLF & _
" "environment": " Test "" & @CRLF & _
"}," & @CRLF & _
"{" & @CRLF & _
" "assessmentID": 289," & @CRLF & _
" "assesmentName": "OneCert "," & @CRLF & _
" "accountName": "9000032"," & @CRLF & _
" "assetName": "OneCert"," & @CRLF & _
" "applicationName": "OneCert "," & @CRLF & _
" "accountType": "zone2.scbdev.net"," & @CRLF & _
" "environment": "Test"" & @CRLF & _
"}"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")