import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?>\\S)(\\s)(?>\")";
final String string = "{\n"
+ " \"assessmentID\": 289,\n"
+ " \"assesmentName\": \" OneCert \",\n"
+ " \"accountName\": \" spadmin \",\n"
+ " \"assetName\": \" OneCert \",\n"
+ " \"applicationName\": \" OneCert \",\n"
+ " \"accountType\": \" LocalAccount \",\n"
+ " \"environment\": \" Test \"\n"
+ "},\n"
+ "{\n"
+ " \"assessmentID\": 289,\n"
+ " \"assesmentName\": \"OneCert \",\n"
+ " \"accountName\": \"9000032\",\n"
+ " \"assetName\": \"OneCert\",\n"
+ " \"applicationName\": \"OneCert \",\n"
+ " \"accountType\": \"zone2.scbdev.net\",\n"
+ " \"environment\": \"Test\"\n"
+ "}";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}