use strict;
my $str = '{
"assessmentID": 289,
"assesmentName": " OneCert ",
"accountName": " spadmin ",
"assetName": " OneCert ",
"applicationName": " OneCert ",
"accountType": " LocalAccount ",
"environment": " Test "
},
{
"assessmentID": 289,
"assesmentName": "OneCert ",
"accountName": "9000032",
"assetName": "OneCert",
"applicationName": "OneCert ",
"accountType": "zone2.scbdev.net",
"environment": "Test"
}';
my $regex = qr/(?>\S)(\s)(?>")/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}