import re
regex = re.compile(r"(?>\S)(\s)(?>\")", flags=re.MULTILINE)
test_str = ("{\n"
" \"assessmentID\": 289,\n"
" \"assesmentName\": \" OneCert \",\n"
" \"accountName\": \" spadmin \",\n"
" \"assetName\": \" OneCert \",\n"
" \"applicationName\": \" OneCert \",\n"
" \"accountType\": \" LocalAccount \",\n"
" \"environment\": \" Test \"\n"
"},\n"
"{\n"
" \"assessmentID\": 289,\n"
" \"assesmentName\": \"OneCert \",\n"
" \"accountName\": \"9000032\",\n"
" \"assetName\": \"OneCert\",\n"
" \"applicationName\": \"OneCert \",\n"
" \"accountType\": \"zone2.scbdev.net\",\n"
" \"environment\": \"Test\"\n"
"}")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")