using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?<=\P{Lu})(?=\p{Lu})";
string substitution = @" ";
string input = @"ThisIsMyCapsDelimitedString";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}