import re
regex = re.compile(r"(?<=\P{Lu})(?=\p{Lu})")
test_str = "ThisIsMyCapsDelimitedString"
subst = " "
result = regex.sub(subst, test_str)
if result:
print(result)