use strict;
my $str = 'ThisIsMyCapsDelimitedString';
my $regex = qr/(?<=\P{Lu})(?=\p{Lu})/p;
my $subst = ' ';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";