re = /(?<=\P{Lu})(?=\p{Lu})/
str = 'ThisIsMyCapsDelimitedString'
subst = ' '
result = str.gsub(re, subst)
# Print the result of the substitution
puts result