const regex = /(?<=\P{Lu})(?=\p{Lu})/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?<=\\P{Lu})(?=\\p{Lu})', 'g')
const str = `ThisIsMyCapsDelimitedString`;
const subst = ` `;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);