$re = '/(?<=\P{Lu})(?=\p{Lu})/';
$str = 'ThisIsMyCapsDelimitedString';
$subst = " ";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;