const regex = /([a-zA-Z1-9])\1{2,}/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('([a-zA-Z1-9])\\1{2,}', 'gm')
const str = `111aabbccxccybbzaa1`;
const subst = `\1\1-`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);