$re = '/([a-zA-Z1-9])\1{2,}/m';
$str = '111aabbccxccybbzaa1';
$subst = "\1\1-";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;