import Foundation
let pattern = #"([a-zA-Z1-9])\1{2,}"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"111aabbccxccybbzaa1"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"\1\1-"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)