use strict;
my $str = '111aabbccxccybbzaa1';
my $regex = qr/([a-zA-Z1-9])\1{2,}/mp;
my $subst = '\\1\\1-';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";