re = /([a-zA-Z1-9])\1{2,}/m
str = '111aabbccxccybbzaa1'
subst = '\\1\\1-'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result