import Foundation
let pattern = #"^\d+\."#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
1.
2.
3.
4.
5.
6.
7.
8.
9.
10.
11.
12.
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"1."#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)