#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "#(\d+) @ (\d+),(\d+): (\d+)x(\d+)"
Local $sString = "#1 @ 338,764: 20x24" & @CRLF & _
"#2 @ 80,667: 12x26" & @CRLF & _
"#3 @ 625,36: 17x22" & @CRLF & _
"#4 @ 196,235: 25x13" & @CRLF & _
"#5 @ 610,700: 25x21" & @CRLF & _
"#6 @ 590,831: 20x13" & @CRLF & _
"#7 @ 253,201: 29x22" & @CRLF & _
"#8 @ 921,577: 15x13" & @CRLF & _
"#9 @ 495,85: 20x19" & @CRLF & _
"#10 @ 397,589: 17x22"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")